Fix config checks for Image Builder and SDK - only build them when requested.
[openwrt.git] / package / Makefile
index e0483de..cd4304e 100644 (file)
@@ -50,11 +50,16 @@ prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile-targets: $(COMPILE_PACKAGES)
 compile:
+       @-rm -f $(PACKAGE_DIR)/*.ipk
        $(MAKE) compile-targets
-install-targets: base-files-install $(INSTALL_PACKAGES)
+
+install-targets: $(INSTALL_PACKAGES)
 install:
        rm -rf $(BUILD_DIR)/root
        $(MAKE) install-targets
+       @if [ -d $(TOPDIR)/files ]; then \
+               $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+       fi
        @( \
                cd $(BUILD_DIR)/root; \
                for script in ./etc/init.d/*; do \