Fix config checks for Image Builder and SDK - only build them when requested.
[openwrt.git] / package / Makefile
index 34eba4e..cd4304e 100644 (file)
@@ -50,8 +50,10 @@ prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile-targets: $(COMPILE_PACKAGES)
 compile:
+       @-rm -f $(PACKAGE_DIR)/*.ipk
        $(MAKE) compile-targets
-install-targets: base-files-install $(INSTALL_PACKAGES)
+
+install-targets: $(INSTALL_PACKAGES)
 install:
        rm -rf $(BUILD_DIR)/root
        $(MAKE) install-targets