let ipkg fail when a package file to be installed is not found
[openwrt.git] / openwrt / package / openh323 / Makefile
index a17ac00..f85e623 100644 (file)
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --enable-audio \
                        --disable-video \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 
@@ -58,11 +59,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link