add downloading script (with md5sum checking and sourceforge downloading support)
[openwrt.git] / openwrt / package / iptables / Makefile
index c50c4bd..9108645 100644 (file)
@@ -38,7 +38,7 @@ endif
 
 $(DL_DIR)/$(PKG_SOURCE_FILE):
        mkdir -p $(DL_DIR)
-       $(WGET) -P $(DL_DIR) $(PKG_SOURCE_SITE)/$(PKG_SOURCE_FILE)
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) x $(PKG_SOURCE_SITE)
 
 $(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
        mkdir -p $(PKG_BUILD_DIR)/modules