[kernel] upgrade to latest kernel versions (2.6.25.4; 2.6.24.7; 2.6.23.17; 2.6.22.19)
[openwrt.git] / include / verbose.mk
index b4242f2..fed83d6 100644 (file)
@@ -8,7 +8,9 @@
 
 ifeq ($(NO_TRACE_MAKE),)
 NO_TRACE_MAKE := $(MAKE) V=99
+SUBMAKE := $(MAKE)
 export NO_TRACE_MAKE
+export SUBMAKE
 endif
 
 ifndef KBUILD_VERBOSE
@@ -19,25 +21,35 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\33[33m"# yellow
-  _N:="\\33[m"#        normal
+  _Y:=\\033[33m
+  _N:=\\033[m
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
+  define MESSAGE
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&3
+  endef
+
   ifeq ($(QUIET),1)
-    $(MAKECMDGOALS): trace
-    trace: FORCE
-       @[ -f "$(MAKECMDGOALS)" ] || { \
-               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
-       }
+    ifneq ($(CURDIR),$(TOPDIR))
+      _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
+    else
+      _DIR:=
+    endif
+    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
+    ))
   else
-    export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=&>/dev/null $(MAKE)
+      MAKE:=>/dev/null 2>&1 $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    export QUIET:=1
+    MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+  define MESSAGE
+    printf "%s\n" "$(1)"
+  endef
 endif