add a new FORCEREBUILD option to Package/<name> to force a package to be rebuilt...
[openwrt.git] / include / verbose.mk
index c998b3d..da2a219 100644 (file)
@@ -6,6 +6,8 @@
 #
 # $Id:$
 
+NO_TRACE_MAKE:=$(MAKE) V=99
+
 ifndef KBUILD_VERBOSE
   KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
@@ -23,7 +25,6 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
-    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
@@ -31,4 +32,6 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+   NO_TRACE_MAKE:=$(MAKE)
 endif