Minor kernel build changes:
[openwrt.git] / include / verbose.mk
index 34568a3..99747ed 100644 (file)
@@ -18,9 +18,9 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
-ifneq ($(shell tty -s <&3 || echo x),x)
-  _Y:="\\33[33m"# yellow
-  _N:="\\33[m"#        normal
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)