more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt.git] / include / verbose.mk
index da2a219..525fbf1 100644 (file)
@@ -6,13 +6,16 @@
 #
 # $Id:$
 
-NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -32,6 +35,4 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
-else
-   NO_TRACE_MAKE:=$(MAKE)
 endif