[swconfig] allow loading port maps from OF
[openwrt.git] / include / uclibc++.mk
index 084ba6a..89298e3 100644 (file)
@@ -5,12 +5,12 @@ ifndef DUMP
 endif
 
 PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+CXX_DEPENDS = @INSTALL_LIBSTDCPP +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
  ifneq ($(CONFIG_CCACHE),)
-  TARGET_CXX_NOCACHE="g++-uc"
+  TARGET_CXX_NOCACHE=g++-uc
  else
-  TARGET_CXX="g++-uc"
+  TARGET_CXX=g++-uc
  endif
 endif