netfilter.mk: fix packaging of xt_LOG.ko, it moved between 3.3.8 and 3.6.x
[openwrt.git] / include / toplevel.mk
index 4bbc58e..19ed8cb 100644 (file)
@@ -1,12 +1,12 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-RELEASE:=Attitude Adjustment
+RELEASE:=Barrier Breaker
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 include $(TOPDIR)/include/verbose.mk
@@ -51,6 +51,8 @@ export SCAN_COOKIE
 
 SUBMAKE:=umask 022; $(SUBMAKE)
 
+ULIMIT_FIX=_limit=`ulimit -n`; [ "$$_limit" = "unlimited" -o "$$_limit" -ge 1024 ] || ulimit -n 1024;
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE
@@ -149,7 +151,7 @@ prereq:: prepare-tmpinfo .config
                        echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
                fi \
        )
-       @+$(SUBMAKE) -r $@
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
 
 help:
        cat README