final fix for the profile selection
[openwrt.git] / include / target.mk
index d0f7b9b..1718a86 100644 (file)
@@ -5,14 +5,16 @@
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.target.mk
 
 define AddProfile
-  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
-    PROFILE=$(1)
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
   endif
 endef
 
+include $(TMP_DIR)/.target.mk
+
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@