final fix for the profile selection
[openwrt.git] / include / target.mk
index 17a41f7..1718a86 100644 (file)
@@ -5,6 +5,14 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
+
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)
@@ -12,6 +20,6 @@ $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@
 else
 $(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
        $(CP) $< $@
 else
 $(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
 endif
 
 endif