remove old variables
[openwrt.git] / include / prereq-build.mk
index 11403c2..c73b124 100644 (file)
@@ -7,6 +7,7 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/host.mk
 
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
@@ -28,6 +29,16 @@ $(eval $(call Require,working-make, \
        Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -74,10 +85,6 @@ $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
 
-$(eval $(call RequireCommand,python, \
-       Please install python. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -93,3 +100,21 @@ $(eval $(call RequireCommand,patch, \
 $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
+
+$(eval $(call RequireCommand,wget, \
+       Please install wget. \
+))
+
+define Require/gnutar
+       $(TAR) --version 2>&1 | grep GNU > /dev/null
+endef
+
+$(eval $(call Require,gnutar, \
+       Please install GNU tar. \
+))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+
+