fix unnecessary rebuilds for library package directories with no selected packages
[openwrt.git] / include / package.mk
index b4b6538..515698d 100644 (file)
@@ -15,17 +15,15 @@ include $(INCLUDE_DIR)/prereq.mk
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifeq ($(CONFIG_AUTOREBUILD),y)
+      _INFO:=
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+        _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
-      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/check_$(1)),$(IPKG_$(1)))
-        $(PKG_BUILD_DIR)/.built: package-rebuild
-      endif
     endif
   endif
 
-
   $(PKG_BUILD_DIR)/.prepared:
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
@@ -123,6 +121,10 @@ define BuildPackage
 
     ifneq ($(CONFIG_PACKAGE_$(1)),)
       compile-targets: $$(IPKG_$(1))
+    else
+      compile-targets: $(1)-disabled
+      $(1)-disabled:
+       @echo "WARNING: skipping $(1) -- package not selected"
     endif
   endif
 
@@ -225,10 +227,23 @@ define BuildPackage
   clean: $(1)-clean
 
   $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
-       -rm $(PKG_BUILD_DIR)/.version-$(1)_*
+       -@rm $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
+
+  ifneq ($$(CONFIG_PACKAGE_$(1)),)
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
+      _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
+
+    ifneq ($(MAKECMDGOALS),prereq)
+      ifneq ($$(_INFO),)
+        $$(info Rebuilding $$(_INFO))
+      endif
+    endif
+  endif
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
@@ -251,12 +266,12 @@ endef
 
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
-       [ -x configure ] && \
-               $(2) \
+       if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               $(2) \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -275,7 +290,7 @@ define Build/Configure/Default
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                $(1); \
-               true; \
+       fi; \
        )
 endef
 
@@ -286,7 +301,6 @@ endef
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \