make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt.git] / include / package.mk
index 8a10569..4e67e73 100644 (file)
@@ -16,15 +16,6 @@ include $(INCLUDE_DIR)/unpack.mk
 
 export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
 
-define shvar
-V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
-endef
-
-define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
-endef
-
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifeq ($(CONFIG_AUTOREBUILD),y)
@@ -290,12 +281,6 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR) ; \
-               [ -e configure.in ] && touch configure.in ; \
-               [ -e aclocal.m4 ] && touch aclocal.m4 ; \
-               [ -e Makefile.in ] && touch Makefile.in ; \
-               [ -e configure ] && touch configure ; \
-       );
        (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \