make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt.git] / include / package.mk
index 05b4ffd..4e67e73 100644 (file)
@@ -14,14 +14,7 @@ include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 
-define shvar
-V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
-endef
-
-define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
-endef
+export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
@@ -256,16 +249,18 @@ define BuildPackage
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
-  ifneq ($$(CONFIG_PACKAGE_$(1)),)
-    ifneq ($(MAKECMDGOALS),prereq)
-      ifneq ($(DUMP),1)
-        ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-          _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
-          $(PKG_BUILD_DIR)/.built: package-rebuild
-        endif
-
-        ifneq ($$(_INFO),)
-          $$(info Rebuilding $$(_INFO))
+  ifdef Package/$(1)/install
+    ifneq ($$(CONFIG_PACKAGE_$(1)),)
+      ifneq ($(MAKECMDGOALS),prereq)
+        ifneq ($(DUMP),1)
+          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+            _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+            $(PKG_BUILD_DIR)/.built: package-rebuild
+          endif
+
+          ifneq ($$(_INFO),)
+            $$(info Rebuilding $$(_INFO))
+          endif
         endif
       endif
     endif
@@ -286,7 +281,7 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR)/$(3); \
+       (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -342,7 +337,7 @@ else
   $(PACKAGE_DIR):
        mkdir -p $@
                
-  ifneq ($(strip $(PKG_SOURCE)),)
+  ifneq ($(strip $(PKG_SOURCE_URL)),)
     download: $(DL_DIR)/$(PKG_SOURCE)
 
     $(DL_DIR)/$(PKG_SOURCE):