[include] package-ipkg.sh: copy the package provides list for all virtual PROVIDES
[openwrt.git] / include / package-ipkg.mk
index e9bac7a..7ff3f6e 100644 (file)
@@ -144,6 +144,7 @@ ifeq ($(DUMP),)
                        fi; \
                done; \
        ) | sort -u > $(PKG_INFO_DIR)/$(1).provides
+       $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$pkg.provides; done)
        $(CheckDependencies)
 
        $(RSTRIP) $$(IDIR_$(1))