kernel: suppress redundant calls to headers installation
[openwrt.git] / include / package-defaults.mk
index 7544292..c349676 100644 (file)
@@ -5,6 +5,12 @@
 # See /LICENSE for more information.
 #
 
+ifneq ($(PKG_NAME),toolchain)
+  PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+else
+  PKG_FIXUP_DEPENDS = $(2)
+endif
+
 define Package/Default
   CONFIGFILE:=
   SECTION:=opt