mac80211: merge upstream fixes
[openwrt.git] / include / package-bin.mk
index 6ee7aed..dcb3a8a 100644 (file)
@@ -7,15 +7,17 @@
 
 ifeq ($(DUMP),)
   define BuildTarget/bin
+    ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
     ifdef Package/$(1)/install
       ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
         compile: install-bin-$(1)
       else
         compile: $(1)-disabled
         $(1)-disabled:
-               @echo "WARNING: skipping $(1) -- package not selected"
+               @echo "WARNING: skipping $(1) -- package not selected" >&2
       endif
     endif
+    endif
 
     install-bin-$(1): $(STAMP_BUILT)
          rm -rf $(BIN_DIR)/$(1)