mvsw61xx: rework chip recognition
[openwrt.git] / include / kernel.mk
index b905cb9..eeb0c3d 100644 (file)
@@ -72,7 +72,7 @@ else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
   LINUX_KARCH := mips
 else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
   LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386))
+else ifneq (,$(findstring $(ARCH), i386 x86_64))
   LINUX_KARCH := x86
 else
   LINUX_KARCH := $(ARCH)