kernel: fix a warning in the O_DIRECT debloat patch
[openwrt.git] / include / kernel-version.mk
index 5f05cf8..fe2203a 100644 (file)
@@ -1,24 +1,15 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.9
-endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.9)
-  LINUX_KERNEL_MD5SUM:=b85b8962840c13f17f944e7b1890f8f8
-endif
-ifeq ($(LINUX_VERSION),2.6.25.20)
-  LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
+ifeq ($(LINUX_VERSION),3.3.8)
+  LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
 endif
-ifeq ($(LINUX_VERSION),2.6.30.10)
-  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
+ifeq ($(LINUX_VERSION),3.6.10)
+  LINUX_KERNEL_MD5SUM:=a8c2dcd268d3ca2b81908990abd5d382
 endif
-ifeq ($(LINUX_VERSION),2.6.31.12)
-  LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
-endif
-ifeq ($(LINUX_VERSION),2.6.32.8)
-  LINUX_KERNEL_MD5SUM:=82023ede52f067fcc55c5e70b02e48ae
+ifeq ($(LINUX_VERSION),3.7)
+  LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
 endif
 
 # disable the md5sum check for unknown kernel versions
@@ -28,5 +19,9 @@ split_version=$(subst ., ,$(1))
 merge_version=$(subst $(space),.,$(1))
 KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
 KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
-KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))
+ifeq ($(firstword $(call split_version,$(KERNEL_BASE))),2)
+  KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))
+else
+  KERNEL_PATCHVER=$(KERNEL)
+endif