add some sanity checking
[openwrt.git] / include / kernel-build.mk
index 9335e1a..b6d2cf5 100644 (file)
@@ -8,10 +8,6 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
-ifneq ($(DUMP),1)
   all: compile
 endif
 
@@ -81,6 +77,7 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+       [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
        touch $(LINUX_CONFIG)
        $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
@@ -101,7 +98,7 @@ define BuildKernel
        @$(MAKE) compile
 
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq