add some sanity checking
[openwrt.git] / include / kernel-build.mk
index 678cf18..b6d2cf5 100644 (file)
@@ -8,10 +8,6 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
-ifneq ($(DUMP),1)
   all: compile
 endif
 
@@ -81,7 +77,9 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+       [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
+       touch $(LINUX_CONFIG)
        $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
        $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
        $(Kernel/Configure)
@@ -100,7 +98,7 @@ define BuildKernel
        @$(MAKE) compile
 
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq