use ~/.openwrt/defconfig as default config if it exists
[openwrt.git] / include / image.mk
index 78e1a2f..eb59ea6 100644 (file)
@@ -79,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+       find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+       find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef