more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt.git] / include / image.mk
index 54f0e8b..ba3cfb8 100644 (file)
@@ -47,7 +47,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   
   ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
     define Image/mkfs/ext2
-               genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
     endef
   endif
@@ -87,7 +87,7 @@ compile-targets:
 install-targets:
 clean-targets:
 
-source:
+download:
 prepare:
 compile: compile-targets
 install: compile install-targets