kernel build cleanup
[openwrt.git] / include / host.mk
index b4580e2..423ca16 100644 (file)
@@ -5,20 +5,33 @@
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
+include $(TMP_DIR)/.host.mk
 
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+export TAR
+
+ifneq ($(__host_inc),1)
+__host_inc:=1
+$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
+       @mkdir -p $(TMP_DIR)
+       @( \
+               HOST_OS=`uname`; \
+               case "$$HOST_OS" in \
+                       Linux) HOST_ARCH=`uname -m`;; \
+                       *) HOST_ARCH=`uname -p`;; \
+               esac; \
+               GNU_HOST_NAME=`gcc -dumpmachine`; \
+               [ -n "$$GNU_HOST_NAME" ] || \
+                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               echo "HOST_OS:=$$HOST_OS" > $@; \
+               echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+               echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+               TAR=`which gtar 2>/dev/null`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
+               echo "TAR:=$$TAR" >> $@; \
+               ZCAT=`which gzcat 2>/dev/null`; \
+               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
+               echo "ZCAT:=$$ZCAT" >> $@; \
+               echo "BASH:=$(shell which bash)" >> $@; \
+       )
+
+endif