[scripts] add a helper script to bundle required libraries for host utilities
[openwrt.git] / include / host-build.mk
index 6fc29b3..40af5c8 100644 (file)
@@ -65,6 +65,12 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_CONFIGURE_CMD = ./configure
 
+ifneq ($(HOST_OS),Darwin)
+  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+    HOST_STATIC_LINKING = -static
+  endif
+endif
+
 define Host/Configure/Default
        (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \