include: cmake: prevent inclusion of rpath in binaries
[openwrt.git] / include / host-build.mk
index 320e74e..2f3c53d 100644 (file)
@@ -55,7 +55,7 @@ HOST_CONFIGURE_VARS = \
        CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CPPFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
-       SHELL="$(BASH)"
+       SHELL="$(SHELL)"
 
 HOST_CONFIGURE_ARGS = \
        --target=$(GNU_HOST_NAME) \
@@ -71,13 +71,7 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_MAKE_FLAGS =
 
-HOST_CONFIGURE_CMD = ./configure
-
-ifneq ($(HOST_OS),Darwin)
-  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
-    HOST_STATIC_LINKING = -static
-  endif
-endif
+HOST_CONFIGURE_CMD = $(BASH) ./configure
 
 define Host/Configure/Default
        $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
@@ -174,6 +168,7 @@ ifndef DUMP
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
+               touch $(HOST_STAMP_BUILT)
                touch $$@
 
   ifndef STAMP_BUILT