switch on new verbose system
[openwrt.git] / Makefile
index 84508b1..a554a1d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,7 @@ RELEASE:=Kamikaze
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -55,22 +56,23 @@ endif
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
-scripts/config/mconf: .config.in
+./scripts/config/mconf: .config.in
        $(MAKE) -C scripts/config all
 
-scripts/config/conf: .config.in
+./scripts/config/conf: .config.in
        $(MAKE) -C scripts/config conf
 
-config: scripts/config/conf FORCE
+config: ./scripts/config/conf FORCE
        $< Config.in
 
-defdconfig: scripts/config/conf FORCE
-       $< -d Config.in
+defconfig: ./scripts/config/conf FORCE
+       touch .config
+       $< -D .config Config.in
 
-oldconfig: scripts/config/conf FORCE
+oldconfig: ./scripts/config/conf FORCE
        $< -o Config.in
 
-menuconfig: scripts/config/mconf FORCE
+menuconfig: ./scripts/config/mconf FORCE
        $< Config.in
 
 config-clean: FORCE
@@ -85,7 +87,16 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world: FORCE
+.config: ./scripts/config/conf FORCE
+       @[ -f .config ] || $(MAKE) menuconfig
+       $< -D .config Config.in >/dev/null 2>/dev/null
+
+download: .config FORCE
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
@@ -95,11 +106,11 @@ world: FORCE
 clean: FORCE
        rm -rf build_* bin
 
-dirclean: clean FORCE
+dirclean: clean
        rm -rf staging_dir_* toolchain_build_*
 
-distclean: dirclean FORCE
-       rm -rf .* dl
+distclean: dirclean config-clean
+       rm -rf dl .*config* .pkg*
 
 .PHONY: FORCE
 FORCE: