add a simple prerequisite check
[openwrt.git] / Makefile
index 5b966b7..25f60e1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -81,11 +81,24 @@ toolchain/%: FORCE
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
        @$< -D .config Config.in &> /dev/null
 
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
        @$< -D .config Config.in &> /dev/null
 
+.prereq: $(TOPDIR)/include/prereq.mk .pkginfo
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: .prereq FORCE
+
 download: .config FORCE
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
 download: .config FORCE
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
+ifeq ($(FORCE),)
+world: .prereq
+endif
+
 world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
 world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile