ar71xx: add separate profiles for the AP121 and AP121-MINI boards
[15.05/openwrt.git] / target / linux / ar71xx / generic / profiles / atheros.mk
index 60b109a..36c918b 100644 (file)
@@ -5,6 +5,28 @@
 # See /LICENSE for more information.
 #
 
+define Profile/AP121
+       NAME:=Atheros AP121 reference board
+       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP121/Description
+       Package set optimized for the Atheros AP121 reference board.
+endef
+
+$(eval $(call Profile,AP121))
+
+define Profile/AP121MINI
+       NAME:=Atheros AP121-MINI reference board
+       PACKAGES:=wpad-mini kmod-ath9k
+endef
+
+define Profile/AP121MINI/Description
+       Package set optimized for the Atheros AP121-MINI reference board.
+endef
+
+$(eval $(call Profile,AP121MINI))
+
 define Profile/AP81
        NAME:=Atheros AP81 reference board
        PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2