[kernel] package ext4 (#4434)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Apr 2009 15:18:49 +0000 (15:18 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Apr 2009 15:18:49 +0000 (15:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15218 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/fs.mk
target/linux/generic-2.6/config-2.6.28

index 7f3ed0c..bfdd45a 100644 (file)
@@ -113,6 +113,28 @@ endef
 
 $(eval $(call KernelPackage,fs-ext3))
 
+define KernelPackage/fs-ext4
+  SUBMENU:=$(FS_MENU)
+  TITLE:=EXT4 filesystem support
+  KCONFIG:= \
+       CONFIG_EXT4DEV_COMPAT=y \
+       CONFIG_EXT4_FS_XATTR=y \
+       CONFIG_EXT4_FS_POSIX_ACL=y \
+       CONFIG_EXT4_FS_SECURITY=y \
+       CONFIG_EXT4_FS
+  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+  FILES:= \
+       $(LINUX_DIR)/fs/ext4/ext4.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,ext4)
+endef
+
+define KernelPackage/fs-ext4/description
+ Kernel module for EXT4 filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-ext4))
+
+
 
 define KernelPackage/fs-hfs
   SUBMENU:=$(FS_MENU)
index 82fbb95..5121fd1 100644 (file)
@@ -789,6 +789,7 @@ CONFIG_ISDN_CAPI_MIDDLEWARE=y
 # CONFIG_IXGB is not set
 # CONFIG_JBD is not set
 # CONFIG_JBD_DEBUG is not set
+# CONFIG_JBD2_DEBUG is not set
 # CONFIG_JFFS2_CMODE_FAVOURLZO is not set
 # CONFIG_JFFS2_CMODE_NONE is not set
 CONFIG_JFFS2_CMODE_PRIORITY=y