Prior to kernel 2.6.23, architecture path was i386, allow that when switching kernel...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Jun 2008 11:08:01 +0000 (11:08 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Jun 2008 11:08:01 +0000 (11:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11594 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc/image/Makefile

index 4da96b7..a8ad099 100644 (file)
@@ -7,8 +7,14 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+ifeq ($(CONFIG_LINUX_2_6_23),y)
+ARCH_PATH=i386
+else
+ARCH_PATH=x86
+endif
+
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
+       $(CP) $(LINUX_DIR)/arch/$(ARCH_PATH)/boot/bzImage $(KDIR)/bzImage
 endef
 
 define trxalign/jffs2-128k