ipq806x: wrap legacy image in uImage
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Sep 2015 14:44:48 +0000 (14:44 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Sep 2015 14:44:48 +0000 (14:44 +0000)
Wrap the zImage in a uImage header so we can easily boot it from legacy
u-boots.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46787 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ipq806x/image/Makefile

index b64d629..2369762 100644 (file)
@@ -38,8 +38,8 @@ endef
 DEVICE_VARS += DEVICE_DTS
 
 define Device/LegacyImage
-       KERNEL_SUFFIX := -zImage
-       KERNEL = kernel-bin | append-dtb
+       KERNEL_SUFFIX := -uImage
+       KERNEL = kernel-bin | append-dtb | uImage none
        KERNEL_NAME := zImage
        KERNEL_INSTALL := 1
 endef