[atheros] experimental support for 2.6.27
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Oct 2008 08:08:13 +0000 (08:08 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Oct 2008 08:08:13 +0000 (08:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12932 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/atheros/config-2.6.27 [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/100-board.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/110-spiflash.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/120-watchdog.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/135-ar2313_2.6.26.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/140-redboot_partition_scan.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/150-bridge-printk.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/200-ar2313_enable_mvswitch.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/901-get_c0_compare_irq_function.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.27/902-mips_clocksource_init_war.patch [new file with mode: 0644]

diff --git a/target/linux/atheros/config-2.6.27 b/target/linux/atheros/config-2.6.27
new file mode 100644 (file)
index 0000000..8e9664e
--- /dev/null
@@ -0,0 +1,235 @@
+CONFIG_32BIT=y
+# CONFIG_64BIT is not set
+CONFIG_AR2313=y
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
+CONFIG_ARCH_POPULATES_NODE_MAP=y
+# CONFIG_ARCH_SUPPORTS_MSI is not set
+CONFIG_ARCH_SUPPORTS_OPROFILE=y
+CONFIG_ARCH_SUSPEND_POSSIBLE=y
+CONFIG_ATHEROS=y
+CONFIG_ATHEROS_AR5312=y
+CONFIG_ATHEROS_AR5315=y
+CONFIG_ATHEROS_AR5315_PCI=y
+CONFIG_ATHEROS_WDT=y
+# CONFIG_ATM is not set
+# CONFIG_ATMEL is not set
+CONFIG_BASE_SMALL=0
+# CONFIG_BCM47XX is not set
+CONFIG_BITREVERSE=y
+# CONFIG_BROADCOM_PHY is not set
+# CONFIG_BT is not set
+CONFIG_CEVT_R4K=y
+CONFIG_CLASSIC_RCU=y
+CONFIG_CMDLINE="console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/preinit"
+CONFIG_CPU_BIG_ENDIAN=y
+CONFIG_CPU_HAS_LLSC=y
+CONFIG_CPU_HAS_PREFETCH=y
+CONFIG_CPU_HAS_SYNC=y
+# CONFIG_CPU_LITTLE_ENDIAN is not set
+# CONFIG_CPU_LOONGSON2 is not set
+CONFIG_CPU_MIPS32=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+# CONFIG_CPU_MIPS64_R1 is not set
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_MIPSR1=y
+# CONFIG_CPU_NEVADA is not set
+# CONFIG_CPU_R10000 is not set
+# CONFIG_CPU_R3000 is not set
+# CONFIG_CPU_R4300 is not set
+# CONFIG_CPU_R4X00 is not set
+# CONFIG_CPU_R5000 is not set
+# CONFIG_CPU_R5432 is not set
+# CONFIG_CPU_R6000 is not set
+# CONFIG_CPU_R8000 is not set
+# CONFIG_CPU_RM7000 is not set
+# CONFIG_CPU_RM9000 is not set
+# CONFIG_CPU_SB1 is not set
+CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
+CONFIG_CPU_SUPPORTS_HIGHMEM=y
+# CONFIG_CPU_TX39XX is not set
+# CONFIG_CPU_TX49XX is not set
+# CONFIG_CPU_VR41XX is not set
+CONFIG_CSRC_R4K=y
+CONFIG_DEVPORT=y
+# CONFIG_DM9000 is not set
+CONFIG_DMA_NEED_PCI_MAP_STATE=y
+CONFIG_DMA_NONCOHERENT=y
+CONFIG_EXTRA_FIRMWARE=""
+# CONFIG_FIRMWARE_IN_KERNEL is not set
+# CONFIG_FIXED_PHY is not set
+CONFIG_FS_POSIX_ACL=y
+CONFIG_GENERIC_CLOCKEVENTS=y
+CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
+CONFIG_GENERIC_CMOS_UPDATE=y
+# CONFIG_GENERIC_FIND_FIRST_BIT is not set
+CONFIG_GENERIC_FIND_NEXT_BIT=y
+CONFIG_GENERIC_GPIO=y
+# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
+CONFIG_GPIO_DEVICE=y
+CONFIG_HAS_DMA=y
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+CONFIG_HAVE_ARCH_KGDB=y
+# CONFIG_HAVE_ARCH_TRACEHOOK is not set
+# CONFIG_HAVE_CLK is not set
+# CONFIG_HAVE_DMA_ATTRS is not set
+# CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS is not set
+# CONFIG_HAVE_GENERIC_DMA_COHERENT is not set
+CONFIG_HAVE_IDE=y
+# CONFIG_HAVE_IOREMAP_PROT is not set
+# CONFIG_HAVE_KPROBES is not set
+# CONFIG_HAVE_KRETPROBES is not set
+CONFIG_HAVE_OPROFILE=y
+# CONFIG_HERMES is not set
+CONFIG_HW_HAS_PCI=y
+CONFIG_HW_RANDOM=y
+# CONFIG_I2C is not set
+CONFIG_ICPLUS_PHY=y
+# CONFIG_IDE is not set
+CONFIG_INITRAMFS_SOURCE=""
+# CONFIG_IPW2100 is not set
+# CONFIG_IPW2200 is not set
+CONFIG_IRQ_CPU=y
+# CONFIG_ISDN is not set
+CONFIG_KMOD=y
+# CONFIG_LEDS_ALIX is not set
+CONFIG_LEDS_GPIO=y
+# CONFIG_LEMOTE_FULONG is not set
+# CONFIG_MACH_ALCHEMY is not set
+# CONFIG_MACH_DECSTATION is not set
+# CONFIG_MACH_JAZZ is not set
+# CONFIG_MACH_TX39XX is not set
+# CONFIG_MACH_TX49XX is not set
+# CONFIG_MACH_VR41XX is not set
+# CONFIG_MDIO_BITBANG is not set
+# CONFIG_MFD_CORE is not set
+# CONFIG_MFD_TMIO is not set
+# CONFIG_MIKROTIK_RB532 is not set
+CONFIG_MIPS=y
+# CONFIG_MIPS_COBALT is not set
+CONFIG_MIPS_L1_CACHE_SHIFT=5
+# CONFIG_MIPS_MALTA is not set
+CONFIG_MIPS_MT_DISABLED=y
+# CONFIG_MIPS_MT_SMP is not set
+# CONFIG_MIPS_MT_SMTC is not set
+# CONFIG_MIPS_SIM is not set
+CONFIG_MTD=y
+# CONFIG_MTD_ABSENT is not set
+CONFIG_MTD_BLKDEVS=y
+CONFIG_MTD_BLOCK=y
+# CONFIG_MTD_BLOCK2MTD is not set
+CONFIG_MTD_CFI=y
+CONFIG_MTD_CFI_ADV_OPTIONS=y
+CONFIG_MTD_CFI_AMDSTD=y
+# CONFIG_MTD_CFI_BE_BYTE_SWAP is not set
+# CONFIG_MTD_CFI_GEOMETRY is not set
+CONFIG_MTD_CFI_I1=y
+CONFIG_MTD_CFI_I2=y
+# CONFIG_MTD_CFI_I4 is not set
+# CONFIG_MTD_CFI_I8 is not set
+# CONFIG_MTD_CFI_INTELEXT is not set
+# CONFIG_MTD_CFI_LE_BYTE_SWAP is not set
+CONFIG_MTD_CFI_NOSWAP=y
+# CONFIG_MTD_CFI_STAA is not set
+CONFIG_MTD_CFI_UTIL=y
+CONFIG_MTD_CHAR=y
+# CONFIG_MTD_CMDLINE_PARTS is not set
+CONFIG_MTD_COMPLEX_MAPPINGS=y
+# CONFIG_MTD_CONCAT is not set
+CONFIG_MTD_GEN_PROBE=y
+# CONFIG_MTD_JEDECPROBE is not set
+CONFIG_MTD_MAP_BANK_WIDTH_1=y
+# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_2=y
+# CONFIG_MTD_MAP_BANK_WIDTH_32 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_4=y
+# CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
+# CONFIG_MTD_MTDRAM is not set
+# CONFIG_MTD_ONENAND is not set
+# CONFIG_MTD_OTP is not set
+CONFIG_MTD_PARTITIONS=y
+# CONFIG_MTD_PCI is not set
+# CONFIG_MTD_PHRAM is not set
+CONFIG_MTD_PHYSMAP=y
+CONFIG_MTD_PHYSMAP_BANKWIDTH=0
+CONFIG_MTD_PHYSMAP_LEN=0x0
+CONFIG_MTD_PHYSMAP_START=0x0
+# CONFIG_MTD_PLATRAM is not set
+# CONFIG_MTD_PMC551 is not set
+# CONFIG_MTD_RAM is not set
+CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-3
+CONFIG_MTD_REDBOOT_PARTS=y
+CONFIG_MTD_REDBOOT_PARTS_READONLY=y
+# CONFIG_MTD_ROM is not set
+# CONFIG_MTD_SLRAM is not set
+CONFIG_MTD_SPIFLASH=y
+CONFIG_MVSWITCH_PHY=y
+# CONFIG_NET_PCI is not set
+CONFIG_NF_CT_ACCT=y
+# CONFIG_NO_IOPORT is not set
+CONFIG_PAGEFLAGS_EXTENDED=y
+# CONFIG_PAGE_SIZE_16KB is not set
+CONFIG_PAGE_SIZE_4KB=y
+# CONFIG_PAGE_SIZE_64KB is not set
+# CONFIG_PAGE_SIZE_8KB is not set
+CONFIG_PCI=y
+CONFIG_PCI_DOMAINS=y
+# CONFIG_PCSPKR_PLATFORM is not set
+CONFIG_PHYLIB=y
+# CONFIG_PMC_MSP is not set
+# CONFIG_PMC_YOSEMITE is not set
+# CONFIG_PNX8550_JBS is not set
+# CONFIG_PNX8550_STB810 is not set
+# CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_QSEMI_PHY is not set
+# CONFIG_REALTEK_PHY is not set
+CONFIG_RFKILL_LEDS=y
+CONFIG_RTC_LIB=y
+CONFIG_RWSEM_GENERIC_SPINLOCK=y
+CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
+CONFIG_SCSI_WAIT_SCAN=m
+# CONFIG_SERIAL_8250_EXTENDED is not set
+CONFIG_SERIAL_8250_NR_UARTS=1
+CONFIG_SERIAL_8250_RUNTIME_UARTS=1
+# CONFIG_SGI_IP22 is not set
+# CONFIG_SGI_IP27 is not set
+# CONFIG_SGI_IP28 is not set
+# CONFIG_SGI_IP32 is not set
+# CONFIG_SIBYTE_BIGSUR is not set
+# CONFIG_SIBYTE_CARMEL is not set
+# CONFIG_SIBYTE_CRHINE is not set
+# CONFIG_SIBYTE_CRHONE is not set
+# CONFIG_SIBYTE_LITTLESUR is not set
+# CONFIG_SIBYTE_RHONE is not set
+# CONFIG_SIBYTE_SENTOSA is not set
+# CONFIG_SIBYTE_SWARM is not set
+# CONFIG_SMSC_PHY is not set
+CONFIG_SND_MIPS=y
+CONFIG_SND_USB=y
+# CONFIG_SOFT_WATCHDOG is not set
+# CONFIG_SPARSEMEM_STATIC is not set
+# CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
+CONFIG_SSB_POSSIBLE=y
+CONFIG_SYSVIPC_SYSCTL=y
+CONFIG_SYS_HAS_CPU_MIPS32_R1=y
+CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
+CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
+CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
+# CONFIG_THERMAL is not set
+# CONFIG_THERMAL_HWMON is not set
+CONFIG_TICK_ONESHOT=y
+CONFIG_TRAD_SIGNALS=y
+CONFIG_USB=m
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_STORAGE_CYPRESS_ATACB=y
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
+CONFIG_USB_WDM=m
+# CONFIG_VGASTATE is not set
+CONFIG_VIDEO_MEDIA=m
+CONFIG_VIDEO_V4L2=m
+CONFIG_VIDEO_V4L2_COMMON=m
+# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/atheros/patches-2.6.27/100-board.patch b/target/linux/atheros/patches-2.6.27/100-board.patch
new file mode 100644 (file)
index 0000000..c5aafc6
--- /dev/null
@@ -0,0 +1,66 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -59,6 +59,18 @@
+       help
+        Support for BCM47XX based boards
++config ATHEROS
++      bool "Atheros SoC support (EXPERIMENTAL)"
++      depends on EXPERIMENTAL
++      select DMA_NONCOHERENT
++      select CEVT_R4K
++      select CSRC_R4K
++      select IRQ_CPU
++      select SYS_HAS_CPU_MIPS32_R1
++      select SYS_SUPPORTS_BIG_ENDIAN
++      select SYS_SUPPORTS_32BIT_KERNEL
++      select GENERIC_GPIO
++
+ config MIPS_COBALT
+       bool "Cobalt Server"
+       select CEVT_R4K
+@@ -598,6 +610,7 @@
+ endchoice
++source "arch/mips/atheros/Kconfig"
+ source "arch/mips/au1000/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -276,6 +276,13 @@
+ load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
+ #
++# Atheros AR5312/AR2312 WiSoC
++#
++core-$(CONFIG_ATHEROS)                += arch/mips/atheros/
++cflags-$(CONFIG_ATHEROS)      += -Iinclude/asm-mips/mach-atheros
++load-$(CONFIG_ATHEROS)                += 0xffffffff80041000
++
++#
+ # Cobalt Server
+ #
+ core-$(CONFIG_MIPS_COBALT)    += arch/mips/cobalt/
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
+@@ -57,6 +57,18 @@
+ #define       MACH_MIKROTIK_RB532     0       /* Mikrotik RouterBoard 532     */
+ #define MACH_MIKROTIK_RB532A  1       /* Mikrotik RouterBoard 532A    */
++/*
++ * Valid machtype for group ATHEROS
++ */
++#define MACH_GROUP_ATHEROS    26
++#define MACH_ATHEROS_AR5312   0
++#define MACH_ATHEROS_AR2312   1
++#define MACH_ATHEROS_AR2313   2
++#define MACH_ATHEROS_AR2315   3
++#define MACH_ATHEROS_AR2316   4
++#define MACH_ATHEROS_AR2317   5
++#define MACH_ATHEROS_AR2318   6
++
+ #define CL_SIZE                       COMMAND_LINE_SIZE
+ extern char *system_type;
diff --git a/target/linux/atheros/patches-2.6.27/110-spiflash.patch b/target/linux/atheros/patches-2.6.27/110-spiflash.patch
new file mode 100644 (file)
index 0000000..e8dbc7a
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/drivers/mtd/devices/Kconfig
++++ b/drivers/mtd/devices/Kconfig
+@@ -83,6 +83,10 @@
+       help
+         This option enables FAST_READ access supported by ST M25Pxx.
++config MTD_SPIFLASH
++      tristate "Atheros AR2315/6/7 SPI Flash support"
++      depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+       tristate "Uncached system RAM"
+       help
+--- a/drivers/mtd/devices/Makefile
++++ b/drivers/mtd/devices/Makefile
+@@ -16,3 +16,4 @@
+ obj-$(CONFIG_MTD_BLOCK2MTD)   += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH)   += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80)      += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH)    += spiflash.o
diff --git a/target/linux/atheros/patches-2.6.27/120-watchdog.patch b/target/linux/atheros/patches-2.6.27/120-watchdog.patch
new file mode 100644 (file)
index 0000000..6822a6d
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -704,6 +704,12 @@
+       help
+         Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
++config ATHEROS_WDT
++      tristate "Atheros wisoc Watchdog Timer"
++      depends on ATHEROS
++      help
++        Hardware driver for the Atheros wisoc Watchdog Timer.
++
+ # PARISC Architecture
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -102,6 +102,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ATHEROS_WDT) += ar2315-wtd.o
+ # PARISC Architecture
diff --git a/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
new file mode 100644 (file)
index 0000000..c615a71
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -359,6 +359,12 @@
+       help
+         Select this if your platform comes with an external 93CX6 eeprom.
++config AR2313
++      tristate "AR2313 Ethernet support"
++      depends on NET_ETHERNET && ATHEROS
++      help
++        Support for the AR231x/531x ethernet controller
++
+ config MACE
+       tristate "MACE (Power Mac ethernet) support"
+       depends on PPC_PMAC && PPC32
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -195,6 +195,7 @@
+ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o
diff --git a/target/linux/atheros/patches-2.6.27/135-ar2313_2.6.26.patch b/target/linux/atheros/patches-2.6.27/135-ar2313_2.6.26.patch
new file mode 100644 (file)
index 0000000..97d3f1c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/drivers/net/ar2313/ar2313.c
++++ b/drivers/net/ar2313/ar2313.c
+@@ -291,7 +291,7 @@
+       sp->mii_bus.write = mdiobus_write;
+       sp->mii_bus.reset = mdiobus_reset;
+       sp->mii_bus.name = "ar2313_eth_mii";
+-      sp->mii_bus.id = 0;
++      snprintf(sp->mii_bus.id, MII_BUS_ID_SIZE, "0");
+       sp->mii_bus.irq = kmalloc(sizeof(int), GFP_KERNEL);
+       *sp->mii_bus.irq = PHY_POLL;
diff --git a/target/linux/atheros/patches-2.6.27/140-redboot_partition_scan.patch b/target/linux/atheros/patches-2.6.27/140-redboot_partition_scan.patch
new file mode 100644 (file)
index 0000000..a76bd83
--- /dev/null
@@ -0,0 +1,54 @@
+--- a/drivers/mtd/redboot.c
++++ b/drivers/mtd/redboot.c
+@@ -60,31 +60,32 @@
+       static char nullstring[] = "unallocated";
+ #endif
++      buf = vmalloc(master->erasesize);
++      if (!buf)
++              return -ENOMEM;
++
++ restart:
+       if ( directory < 0 ) {
+               offset = master->size + directory * master->erasesize;
+-              while (master->block_isbad && 
++              while (master->block_isbad &&
+                      master->block_isbad(master, offset)) {
+                       if (!offset) {
+                       nogood:
+                               printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
++                              vfree(buf);
+                               return -EIO;
+                       }
+                       offset -= master->erasesize;
+               }
+       } else {
+               offset = directory * master->erasesize;
+-              while (master->block_isbad && 
++              while (master->block_isbad &&
+                      master->block_isbad(master, offset)) {
+                       offset += master->erasesize;
+                       if (offset == master->size)
+                               goto nogood;
+               }
+       }
+-      buf = vmalloc(master->erasesize);
+-
+-      if (!buf)
+-              return -ENOMEM;
+-
+       printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
+              master->name, offset);
+@@ -156,6 +157,11 @@
+       }
+       if (i == numslots) {
+               /* Didn't find it */
++              if (offset + master->erasesize < master->size) {
++                      /* not at the end of the flash yet, maybe next block :) */
++                      directory++;
++                      goto restart;
++              }
+               printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
+                      master->name);
+               ret = 0;
diff --git a/target/linux/atheros/patches-2.6.27/150-bridge-printk.patch b/target/linux/atheros/patches-2.6.27/150-bridge-printk.patch
new file mode 100644 (file)
index 0000000..0c4dd0a
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/net/core/dev.c
++++ b/net/core/dev.c
+@@ -3983,8 +3983,8 @@
+       /* Fix illegal SG+CSUM combinations. */
+       if ((dev->features & NETIF_F_SG) &&
+           !(dev->features & NETIF_F_ALL_CSUM)) {
+-              printk(KERN_NOTICE "%s: Dropping NETIF_F_SG since no checksum feature.\n",
+-                     dev->name);
++              //printk(KERN_NOTICE "%s: Dropping NETIF_F_SG since no checksum feature.\n",
++              //       dev->name);
+               dev->features &= ~NETIF_F_SG;
+       }
+@@ -3997,9 +3997,9 @@
+       }
+       if (dev->features & NETIF_F_UFO) {
+               if (!(dev->features & NETIF_F_HW_CSUM)) {
+-                      printk(KERN_ERR "%s: Dropping NETIF_F_UFO since no "
+-                                      "NETIF_F_HW_CSUM feature.\n",
+-                                                      dev->name);
++                      //printk(KERN_ERR "%s: Dropping NETIF_F_UFO since no "
++                      //              "NETIF_F_HW_CSUM feature.\n",
++                      //                              dev->name);
+                       dev->features &= ~NETIF_F_UFO;
+               }
+               if (!(dev->features & NETIF_F_SG)) {
diff --git a/target/linux/atheros/patches-2.6.27/200-ar2313_enable_mvswitch.patch b/target/linux/atheros/patches-2.6.27/200-ar2313_enable_mvswitch.patch
new file mode 100644 (file)
index 0000000..752b07f
--- /dev/null
@@ -0,0 +1,34 @@
+--- a/drivers/net/ar2313/ar2313.c
++++ b/drivers/net/ar2313/ar2313.c
+@@ -953,9 +953,9 @@
+                                               ((status >> DMA_RX_LEN_SHIFT) & 0x3fff) - CRC_LEN);
+                               dev->stats.rx_bytes += skb->len;
+-                              skb->protocol = eth_type_trans(skb, dev);
++
+                               /* pass the packet to upper layers */
+-                              netif_rx(skb);
++                              sp->rx(skb);
+                               skb_new->dev = dev;
+                               /* 16 bit align */
+@@ -1370,6 +1370,8 @@
+               return PTR_ERR(phydev);
+       }
++      sp->rx = phydev->netif_rx;
++
+       /* mask with MAC supported features */
+       phydev->supported &= (SUPPORTED_10baseT_Half
+               | SUPPORTED_10baseT_Full
+--- a/drivers/net/ar2313/ar2313.h
++++ b/drivers/net/ar2313/ar2313.h
+@@ -107,6 +107,8 @@
+  */
+ struct ar2313_private {
+       struct net_device *dev;
++      int (*rx)(struct sk_buff *skb);
++
+       int version;
+       u32 mb[2];
diff --git a/target/linux/atheros/patches-2.6.27/901-get_c0_compare_irq_function.patch b/target/linux/atheros/patches-2.6.27/901-get_c0_compare_irq_function.patch
new file mode 100644 (file)
index 0000000..32b3ae4
--- /dev/null
@@ -0,0 +1,43 @@
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
+@@ -45,6 +45,7 @@
+ #include <asm/mmu_context.h>
+ #include <asm/types.h>
+ #include <asm/stacktrace.h>
++#include <asm/time.h>
+ extern void check_wait(void);
+ extern asmlinkage void r4k_wait(void);
+@@ -1484,6 +1485,8 @@
+        */
+       if (cpu_has_mips_r2) {
+               cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
++              if (get_c0_compare_irq)
++                      cp0_compare_irq = get_c0_compare_irq();
+               cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
+               if (cp0_perfcount_irq == cp0_compare_irq)
+                       cp0_perfcount_irq = -1;
+--- a/include/asm-mips/time.h
++++ b/include/asm-mips/time.h
+@@ -53,6 +53,7 @@
+ #ifdef CONFIG_CEVT_R4K
+ extern int mips_clockevent_init(void);
+ extern unsigned int __weak get_c0_compare_int(void);
++extern unsigned int __weak get_c0_compare_irq(void);
+ #else
+ static inline int mips_clockevent_init(void)
+ {
+--- a/arch/mips/atheros/board.c
++++ b/arch/mips/atheros/board.c
+@@ -205,6 +205,11 @@
+ void __init plat_time_init(void) {
+     board_time_init();
+ }
++
++unsigned int __cpuinit get_c0_compare_irq(void)
++{
++      return CP0_LEGACY_COMPARE_IRQ;
++}
+ #endif
+ void __init arch_init_irq(void)
diff --git a/target/linux/atheros/patches-2.6.27/902-mips_clocksource_init_war.patch b/target/linux/atheros/patches-2.6.27/902-mips_clocksource_init_war.patch
new file mode 100644 (file)
index 0000000..564321c
--- /dev/null
@@ -0,0 +1,56 @@
+--- a/arch/mips/kernel/cevt-r4k.c
++++ b/arch/mips/kernel/cevt-r4k.c
+@@ -15,6 +15,22 @@
+ #include <asm/cevt-r4k.h>
+ /*
++ * Compare interrupt can be routed and latched outside the core,
++ * so a single execution hazard barrier may not be enough to give
++ * it time to clear as seen in the Cause register.  4 time the
++ * pipeline depth seems reasonably conservative, and empirically
++ * works better in configurations with high CPU/bus clock ratios.
++ */
++
++#define compare_change_hazard() \
++      do { \
++              irq_disable_hazard(); \
++              irq_disable_hazard(); \
++              irq_disable_hazard(); \
++              irq_disable_hazard(); \
++      } while (0)
++
++/*
+  * The SMTC Kernel for the 34K, 1004K, et. al. replaces several
+  * of these routines with SMTC-specific variants.
+  */
+@@ -30,6 +46,7 @@
+       cnt = read_c0_count();
+       cnt += delta;
+       write_c0_compare(cnt);
++      compare_change_hazard();
+       res = ((int)(read_c0_count() - cnt) > 0) ? -ETIME : 0;
+       return res;
+ }
+@@ -99,22 +116,6 @@
+       return (read_c0_cause() >> cp0_compare_irq) & 0x100;
+ }
+-/*
+- * Compare interrupt can be routed and latched outside the core,
+- * so a single execution hazard barrier may not be enough to give
+- * it time to clear as seen in the Cause register.  4 time the
+- * pipeline depth seems reasonably conservative, and empirically
+- * works better in configurations with high CPU/bus clock ratios.
+- */
+-
+-#define compare_change_hazard() \
+-      do { \
+-              irq_disable_hazard(); \
+-              irq_disable_hazard(); \
+-              irq_disable_hazard(); \
+-              irq_disable_hazard(); \
+-      } while (0)
+-
+ int c0_compare_int_usable(void)
+ {
+       unsigned int delta;