generic/4.4: update to 4.4-rc7
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Jan 2016 22:02:47 +0000 (22:02 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Jan 2016 22:02:47 +0000 (22:02 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48059 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch [deleted file]
target/linux/generic/patches-4.4/650-pppoe_header_pad.patch
target/linux/generic/patches-4.4/700-swconfig.patch
target/linux/generic/patches-4.4/901-debloat_sock_diag.patch
target/linux/generic/patches-4.4/902-debloat_proc.patch

index b5b5fc4..97dc592 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.1 = .13
 LINUX_VERSION-4.3 =
-LINUX_VERSION-4.4 = -rc5
+LINUX_VERSION-4.4 = -rc7
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.1.13 = af9dd5d8f71185a64a8eccface15fc00
 LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
-LINUX_KERNEL_MD5SUM-4.4-rc5 = 7516a83ce861c7b2324975c82c413157
+LINUX_KERNEL_MD5SUM-4.4-rc7 = 7f4b1d85736a180df73af45adde8937b
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch b/target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch
deleted file mode 100644 (file)
index b8b9a83..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Date: Sat, 5 Dec 2015 13:53:36 +0100
-Subject: [PATCH] net: remove unnecessary semicolon in
- netdev_alloc_pcpu_stats()
-
-This semicolon causes a build error if the function call is wrapped in
-parentheses.
-
-Fixes: aabc92bbe3cf ("net: add __netdev_alloc_pcpu_stats() to indicate gfp flags")
-Reported-by: Imre Kaloz <kaloz@openwrt.org>
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
----
-
---- a/include/linux/netdevice.h
-+++ b/include/linux/netdevice.h
-@@ -2084,7 +2084,7 @@ struct pcpu_sw_netstats {
- })
- #define netdev_alloc_pcpu_stats(type)                                 \
--      __netdev_alloc_pcpu_stats(type, GFP_KERNEL);
-+      __netdev_alloc_pcpu_stats(type, GFP_KERNEL)
- #include <linux/notifier.h>
index 2804469..adba206 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ppp/pppoe.c
 +++ b/drivers/net/ppp/pppoe.c
-@@ -871,7 +871,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -877,7 +877,7 @@ static int pppoe_sendmsg(struct socket *
                goto end;
  
  
@@ -9,7 +9,7 @@
                           0, GFP_KERNEL);
        if (!skb) {
                error = -ENOMEM;
-@@ -879,7 +879,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -885,7 +885,7 @@ static int pppoe_sendmsg(struct socket *
        }
  
        /* Reserve space for headers. */
index 7f62741..122dd44 100644 (file)
@@ -29,7 +29,7 @@
  obj-$(CONFIG_DAVICOM_PHY)     += davicom.o
 --- a/include/uapi/linux/Kbuild
 +++ b/include/uapi/linux/Kbuild
-@@ -387,6 +387,7 @@ header-y += stddef.h
+@@ -388,6 +388,7 @@ header-y += stddef.h
  header-y += string.h
  header-y += suspend_ioctls.h
  header-y += swab.h
index a33f330..b70f44e 100644 (file)
@@ -25,7 +25,7 @@
  obj-$(CONFIG_PROC_FS) += net-procfs.o
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -1470,9 +1470,11 @@ void sk_destruct(struct sock *sk)
+@@ -1469,9 +1469,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 57ceeae..9f77858 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3036,6 +3036,8 @@ static __net_initdata struct pernet_oper
+@@ -3035,6 +3035,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {