fix flac build when arch != mipsel
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Oct 2005 01:39:00 +0000 (01:39 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Oct 2005 01:39:00 +0000 (01:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2169 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/flac/Makefile
openwrt/package/flac/patches/no_encoder.patch

index 9baa0da..281b2c4 100644 (file)
@@ -26,6 +26,7 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lite \
                $(TARGET_CONFIGURE_OPTS) \
+               RELEASE_CFLAGS="$(TARGET_CFLAGS)" \
                libFLAC
        touch $@
 
index 64666e8..f1d6fe2 100644 (file)
@@ -6,7 +6,7 @@ diff -ru flac-1.1.2.OLD/build/lib.mk flac-1.1.2.NEW/build/lib.mk
  debug   : CFLAGS = -g -O0 -DDEBUG $(CONFIG_CFLAGS) $(DEBUG_CFLAGS) -Wall -W -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
  valgrind: CFLAGS = -g -O0 -DDEBUG $(CONFIG_CFLAGS) $(DEBUG_CFLAGS) -DFLAC__VALGRIND_TESTING -Wall -W -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
 -release : CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
-+release : CFLAGS = -Os -pipe -mips32 -mtune=mips32 -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
++release : CFLAGS = -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
  
  LFLAGS  = -L$(LIBPATH)