madwifi: Fix linux 3.0 detection
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 15 Jun 2011 21:17:17 +0000 (21:17 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 15 Jun 2011 21:17:17 +0000 (21:17 +0000)
Allows madwifi to be built against linux 3.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27188 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/patches/476-3.0_detection_fix.patch [new file with mode: 0644]

diff --git a/package/madwifi/patches/476-3.0_detection_fix.patch b/package/madwifi/patches/476-3.0_detection_fix.patch
new file mode 100644 (file)
index 0000000..2f8bfb4
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -155,13 +155,15 @@ unload:
+ configcheck:
+       @echo -n "Checking kernel configuration... "
+       
+-      @# check version of kernel
+-      @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
+-          echo "FAILED"; \
+-          echo "Only kernel versions 2.4.x and above are supported."; \
+-          echo "You have $(KERNELRELEASE)."; \
+-          exit 1; \
+-      }
++      @# check kernel version
++      @case $(KERNELRELEASE) in \
++          2.[456].*) ;; \
++          [3-9].*) ;; \
++          *) echo "FAILED"; \
++             echo "Only kernel versions 2.4.x and above are supported."; \
++             echo "You have $(KERNELRELEASE)."; \
++             exit 1 ;; \
++      esac
+       
+       @# check kernel configuration
+       @if [ -z "$(CONFIG_SYSCTL)" ]; then \