Update popt release (fix ipkg/rules clean)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Mar 2005 03:57:04 +0000 (03:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Mar 2005 03:57:04 +0000 (03:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@348 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/popt/Makefile
package/popt/popt-1.7-2.diff [deleted file]
package/popt/popt-1.7-3.diff [new file with mode: 0644]

index ac05eb5..e00a10b 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME := popt
 PKG_VERSION := 1.7
-PKG_RELEASE := 2
+PKG_RELEASE := 3
 
 PKG_SOURCE_SITE := ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
 PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -39,8 +39,11 @@ compile: $(PKG_IPK)
 install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
 
 clean:
+       -cd $(PKG_BUILD_DIR); \
+       ipkg/rules \
+         TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
+         INSTALL_DIR="$(STAGING_DIR)" \
+        clean
        rm -rf $(PKG_BUILD_DIR)
-       rm -f $(STAGING_DIR)/usr/include/popt.h
-       rm -f $(STAGING_DIR)/usr/lib/libpopt\*
-       rm -f $(PACKAGE_DIR)/lib$(PKG_NAME)\*.ipk
+       rm -r $(PKG_IPK)
 
diff --git a/package/popt/popt-1.7-2.diff b/package/popt/popt-1.7-2.diff
deleted file mode 100644 (file)
index 9cff3c9..0000000
+++ /dev/null
@@ -1,146 +0,0 @@
-diff -ruN popt-1.7-orig/ipkg/libpopt/CONTROL/control popt-1.7-2/ipkg/libpopt/CONTROL/control
---- popt-1.7-orig/ipkg/libpopt/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
-+++ popt-1.7-2/ipkg/libpopt/CONTROL/control    2005-02-27 16:29:21.000000000 +0100
-@@ -0,0 +1,8 @@
-+Package: libpopt
-+Priority: optional
-+Section: libs
-+Version: 1.7-2
-+Architecture: mipsel
-+Maintainer: Nico <nthill@free.fr>
-+Source: http://nthill.free.fr/openwrt/sources/popt/
-+Description: a command line option parsing library
-diff -ruN popt-1.7-orig/ipkg/libpopt-dev/CONTROL/control popt-1.7-2/ipkg/libpopt-dev/CONTROL/control
---- popt-1.7-orig/ipkg/libpopt-dev/CONTROL/control     1970-01-01 01:00:00.000000000 +0100
-+++ popt-1.7-2/ipkg/libpopt-dev/CONTROL/control        2005-02-27 16:29:29.000000000 +0100
-@@ -0,0 +1,8 @@
-+Package: libpopt-dev
-+Priority: optional
-+Section: devel
-+Version: 1.7-2
-+Architecture: mipsel
-+Maintainer: Nico <nthill@free.fr>
-+Source: http://nthill.free.fr/openwrt/sources/popt/
-+Description: a command line option parsing library (development)
-diff -ruN popt-1.7-orig/ipkg/rules popt-1.7-2/ipkg/rules
---- popt-1.7-orig/ipkg/rules   1970-01-01 01:00:00.000000000 +0100
-+++ popt-1.7-2/ipkg/rules      2005-02-27 16:31:03.000000000 +0100
-@@ -0,0 +1,118 @@
-+#!/usr/bin/make -f
-+
-+ifneq ($(strip ${IPKG_RULES_INC}),)
-+  include $(IPKG_RULES_INC)
-+endif
-+
-+##
-+
-+CURRENT_DIR := $(shell pwd)
-+
-+INSTALL_DIR = $(CURRENT_DIR)/ipkg-install
-+
-+I_LIBPOPT := ipkg/libpopt
-+I_LIBPOPT_DEV := ipkg/libpopt-dev
-+
-+BUILD_DEPS := \
-+
-+##
-+
-+all: package
-+
-+.stamp-configured: $(BUILD_DEPS)
-+
-+      rm -rf config.cache
-+      $(TARGET_CONFIGURE_OPTS) \
-+      CFLAGS="$(TARGET_CFLAGS)" \
-+      am_cv_func_iconv=no \
-+      ./configure \
-+        --target=$(GNU_TARGET_NAME) \
-+        --host=$(GNU_TARGET_NAME) \
-+        --build=$(GNU_HOST_NAME) \
-+        --prefix=/usr \
-+        --exec-prefix=/usr \
-+        --bindir=/usr/bin \
-+        --datadir=/usr/share \
-+        --includedir=/usr/include \
-+        --infodir=/usr/share/info \
-+        --libdir=/usr/lib \
-+        --libexecdir=/usr/lib \
-+        --localstatedir=/var \
-+        --mandir=/usr/share/man \
-+        --sbindir=/usr/sbin \
-+        --sysconfdir=/etc \
-+        $(DISABLE_NLS) \
-+        --enable-shared \
-+        --enable-static \
-+
-+      touch .stamp-configured
-+
-+
-+.stamp-built: .stamp-configured
-+
-+      $(MAKE) \
-+        $(TARGET_CONFIGURE_OPTS) \
-+        CFLAGS="$(TARGET_CFLAGS)" \
-+        
-+      touch .stamp-built
-+
-+
-+$(INSTALL_DIR)/usr/include/popt.h: .stamp-built
-+
-+      mkdir -p $(INSTALL_DIR)
-+
-+      $(MAKE) \
-+        DESTDIR="$(INSTALL_DIR)" \
-+        program_transform_name="s,x,x," \
-+       install
-+
-+
-+configure: .stamp-configured
-+
-+
-+build: .stamp-built
-+
-+
-+install: $(INSTALL_DIR)/usr/include/popt.h
-+
-+
-+package: $(INSTALL_DIR)/usr/include/popt.h
-+
-+      mkdir -p $(I_LIBPOPT)/usr/lib
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so.* $(I_LIBPOPT)/usr/lib/
-+      $(STRIP) $(I_LIBPOPT)/usr/lib/lib*.so.*
-+
-+      mkdir -p $(I_LIBPOPT_DEV)/usr/include
-+      cp -fpR $(INSTALL_DIR)/usr/include/popt.h $(I_LIBPOPT_DEV)/usr/include/
-+      mkdir -p $(I_LIBPOPT_DEV)/usr/lib
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.a $(I_LIBPOPT_DEV)/usr/lib/
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so* $(I_LIBPOPT_DEV)/usr/lib/
-+
-+      chmod 0755 $(I_LIBPOPT)/CONTROL/
-+      chmod 0644 $(I_LIBPOPT)/CONTROL/control
-+
-+      chmod 0755 $(I_LIBPOPT_DEV)/CONTROL/
-+      chmod 0644 $(I_LIBPOPT_DEV)/CONTROL/control
-+
-+      $(IPKG_BUILD) $(I_LIBPOPT) $(IPKG_TARGET_DIR)
-+      $(IPKG_BUILD) $(I_LIBPOPT_DEV) $(IPKG_TARGET_DIR)
-+
-+
-+clean:
-+
-+      -$(MAKE) clean
-+      rm -rf .stamp-*
-+      rm -rf $(INSTALL_DIR)
-+      rm -rf $(I_LIBPOPT)/usr
-+      rm -rf $(I_LIBPOPT_DEV)/usr
-+
-+
-+control:
-+
-+      @cat $(I_LIBPOPT)/CONTROL/control
-+      @echo
-+      @cat $(I_LIBPOPT_DEV)/CONTROL/control
-+      @echo
-+      
-+
-+.PHONY: configure build install package clean control
diff --git a/package/popt/popt-1.7-3.diff b/package/popt/popt-1.7-3.diff
new file mode 100644 (file)
index 0000000..4aa9b8e
--- /dev/null
@@ -0,0 +1,159 @@
+diff -ruN popt-1.7-orig/ipkg/libpopt/CONTROL/control popt-1.7-3/ipkg/libpopt/CONTROL/control
+--- popt-1.7-orig/ipkg/libpopt/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
++++ popt-1.7-3/ipkg/libpopt/CONTROL/control    2005-03-08 03:24:11.000000000 +0100
+@@ -0,0 +1,8 @@
++Package: libpopt
++Priority: optional
++Section: libs
++Version: [TBDL]
++Architecture: [TBDL]
++Maintainer: Nico <nthill@free.fr>
++Source: http://nthill.free.fr/openwrt/sources/popt/
++Description: a command line option parsing library
+diff -ruN popt-1.7-orig/ipkg/popt-dev/CONTROL/control popt-1.7-3/ipkg/popt-dev/CONTROL/control
+--- popt-1.7-orig/ipkg/popt-dev/CONTROL/control        1970-01-01 01:00:00.000000000 +0100
++++ popt-1.7-3/ipkg/popt-dev/CONTROL/control   2005-03-08 03:26:21.000000000 +0100
+@@ -0,0 +1,8 @@
++Package: popt-dev
++Priority: optional
++Section: devel
++Version: [TBDL]
++Architecture: [TBDL]
++Maintainer: Nico <nthill@free.fr>
++Source: http://nthill.free.fr/openwrt/sources/popt/
++Description: a command line option parsing library (development)
+diff -ruN popt-1.7-orig/ipkg/rules popt-1.7-3/ipkg/rules
+--- popt-1.7-orig/ipkg/rules   1970-01-01 01:00:00.000000000 +0100
++++ popt-1.7-3/ipkg/rules      2005-03-08 03:50:49.000000000 +0100
+@@ -0,0 +1,126 @@
++#!/usr/bin/make -f
++
++ifneq ($(strip ${IPKG_RULES_INC}),)
++  include $(IPKG_RULES_INC)
++endif
++
++##
++
++PKG_VERSION := $(shell cat ./ipkg/version)
++CURRENT_DIR := $(shell pwd)
++INSTALL_DIR = $(CURRENT_DIR)/ipkg-install
++
++I_LIBPOPT := ipkg/libpopt
++I_POPT_DEV := ipkg/popt-dev
++
++BUILD_DEPS := \
++
++CONFIGURE_OPTS = \
++      --enable-shared \
++      --enable-static \
++
++##
++
++all: package
++
++
++.stamp-configured: $(BUILD_DEPS)
++
++      rm -rf config.cache
++      $(TARGET_CONFIGURE_OPTS) \
++      CFLAGS="$(TARGET_CFLAGS)" \
++      am_cv_func_iconv=no \
++      ./configure \
++        --target=$(GNU_TARGET_NAME) \
++        --host=$(GNU_TARGET_NAME) \
++        --build=$(GNU_HOST_NAME) \
++        --prefix=/usr \
++        --exec-prefix=/usr \
++        --bindir=/usr/bin \
++        --datadir=/usr/share \
++        --includedir=/usr/include \
++        --infodir=/usr/share/info \
++        --libdir=/usr/lib \
++        --libexecdir=/usr/lib \
++        --localstatedir=/var \
++        --mandir=/usr/share/man \
++        --sbindir=/usr/sbin \
++        --sysconfdir=/etc \
++        $(DISABLE_NLS) \
++        $(CONFIGURE_OPTS) \
++
++      touch .stamp-configured
++
++
++.stamp-built: .stamp-configured
++
++      $(MAKE) \
++        $(TARGET_CONFIGURE_OPTS) \
++        CFLAGS="$(TARGET_CFLAGS)" \
++        
++      touch .stamp-built
++
++
++$(INSTALL_DIR)/usr/include/popt.h: .stamp-built
++
++      mkdir -p $(INSTALL_DIR)
++
++      $(MAKE) \
++        DESTDIR="$(INSTALL_DIR)" \
++        transform="s,x,x," \
++       install
++
++
++configure: .stamp-configured
++
++
++build: .stamp-built
++
++
++install: $(INSTALL_DIR)/usr/include/popt.h
++
++
++package: $(INSTALL_DIR)/usr/include/popt.h
++
++      mkdir -p $(I_LIBPOPT)/usr/lib
++      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so.* $(I_LIBPOPT)/usr/lib/
++      $(STRIP) $(I_LIBPOPT)/usr/lib/lib*.so.*
++
++      mkdir -p $(I_POPT_DEV)/usr/include
++      cp -fpR $(INSTALL_DIR)/usr/include/popt.h $(I_POPT_DEV)/usr/include/
++      mkdir -p $(I_POPT_DEV)/usr/lib
++      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.a $(I_POPT_DEV)/usr/lib/
++      cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so* $(I_POPT_DEV)/usr/lib/
++
++      chmod 0755 ipkg/*/CONTROL/
++      chmod 0644 ipkg/*/CONTROL/control
++      
++      perl -pi -e "s/^Arch.*:.*/Architecture: $(TARGET_ARCH)/g" ipkg/*/CONTROL/control
++ifneq ($(strip $(PKG_VERSION)),)
++      perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
++endif
++
++      $(IPKG_BUILD) $(I_LIBPOPT) $(IPKG_TARGET_DIR)
++      $(IPKG_BUILD) $(I_POPT_DEV) $(IPKG_TARGET_DIR)
++
++
++clean:
++
++      -$(MAKE) clean
++      rm -rf .stamp-*
++      rm -rf $(INSTALL_DIR)/usr/include/popt*
++      rm -rf $(INSTALL_DIR)/usr/include/libpopt*
++      rm -rf $(INSTALL_DIR)/usr/share/man/man*/popt*
++      rm -rf $(I_LIBPOPT)/usr
++      rm -rf $(I_POPT_DEV)/usr
++
++
++control:
++
++      @cat $(I_LIBPOPT)/CONTROL/control
++      @echo
++      @cat $(I_POPT_DEV)/CONTROL/control
++      @echo
++      
++
++.PHONY: configure build install package clean control
+diff -ruN popt-1.7-orig/ipkg/version popt-1.7-3/ipkg/version
+--- popt-1.7-orig/ipkg/version 1970-01-01 01:00:00.000000000 +0100
++++ popt-1.7-3/ipkg/version    2005-03-08 03:23:49.000000000 +0100
+@@ -0,0 +1 @@
++1.7-3