packages: more (e)glibc fixes after r44701
authorNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:32:22 +0000 (12:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:32:22 +0000 (12:32 +0000)
_GNU_SOURCE has been declared "deprecated" in favor of _DEFAULT_SOURCE in glibc

Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44843 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/uhttpd/Makefile
package/utils/ugps/Makefile

index 7c0989d..f4de987 100644 (file)
@@ -107,6 +107,10 @@ define Package/uhttpd/conffiles
 /etc/uhttpd.key
 endef
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on
index c1bc7cd..3662125 100644 (file)
@@ -32,6 +32,10 @@ endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 define Package/ugps/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/