add missing piece from whiterussian image building makefile to trunk/
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Oct 2005 18:55:48 +0000 (18:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Oct 2005 18:55:48 +0000 (18:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2250 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/image/brcm/Makefile

index 73d236a..31f941f 100644 (file)
@@ -25,8 +25,13 @@ endif
 ifeq ($(FS),jffs2-4MB)
 TRXALIGN:=-a 0x10000
 endif
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
-       $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+
+$(KDIR)/loader.tmp.gz:
+       cp $(BUILD_DIR)/loader.gz $@
+       echo -ne "\\x00" >> $@
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/loader.tmp.gz
+       $(STAGING_DIR)/bin/trx -o $@ $(KDIR)/loader.tmp.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
 
 ifeq ($(KERNEL),2.6)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))