kernel/acx-mac80211: fix autoloading on boot
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Dec 2014 19:35:36 +0000 (19:35 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Dec 2014 19:35:36 +0000 (19:35 +0000)
The kernel build system cannot track dependencies of out-of-tree
modules, making the buildsystem fail to load mac80211.

Add mac80211 as an explicit load to ensure all required modules are
loaded.

Fixes #16522.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43631 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/acx-mac80211/Makefile

index 16f6f5d..dfb73f7 100644 (file)
@@ -32,7 +32,7 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX1xx mac80211 driver
   DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
-  AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
+  AUTOLOAD:=$(call AutoLoad,50,mac80211 acx-mac80211)
   MAINTAINER:=Florian Fainelli <florian@openwrt.org>
   MENU:=1
 endef