ext4: add Support for large (2TB+) block devices and files
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Feb 2010 20:14:24 +0000 (20:14 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Feb 2010 20:14:24 +0000 (20:14 +0000)
CONFIG_LBDAF is needed for mounting ext4 filesystems with huge_file enabled.
This is the default option.

This closes #6714.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19799 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/fs.mk
target/linux/generic-2.6/config-2.6.25
target/linux/generic-2.6/config-2.6.30
target/linux/generic-2.6/config-2.6.31
target/linux/generic-2.6/config-2.6.32

index 08d814d..c86ef34 100644 (file)
@@ -61,7 +61,7 @@ $(eval $(call KernelPackage,fs-ntfs))
 
 define KernelPackage/fs-mbcache
   SUBMENU:=$(FS_MENU)
-  TITLE:=mbcache (used by ext2/ext3)
+  TITLE:=mbcache (used by ext2/ext3/ext4)
   KCONFIG:=CONFIG_FS_MBCACHE
   ifneq ($(CONFIG_FS_MBCACHE),)
     FILES:=$(LINUX_DIR)/fs/mbcache.$(LINUX_KMOD_SUFFIX)
@@ -115,17 +115,16 @@ define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
   KCONFIG:= \
-       CONFIG_EXT4DEV_COMPAT=y \
        CONFIG_EXT4_FS_XATTR=y \
        CONFIG_EXT4_FS_POSIX_ACL=y \
        CONFIG_EXT4_FS_SECURITY=y \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
-  DEPENDS:= @LINUX_2_6 +kmod-crc16 $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+  DEPENDS:= @LINUX_2_6 +kmod-crc16 +kmod-crc32 $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
   FILES:= \
        $(LINUX_DIR)/fs/ext4/ext4.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/fs/jbd2/jbd2.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,jbd2 $(EXT4_NAME))
+  AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4)
 endef
 
 define KernelPackage/fs-ext4/description
index 3ac9274..3ee9904 100644 (file)
@@ -758,7 +758,7 @@ CONFIG_JOLIET=y
 CONFIG_KMOD=y
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
-# CONFIG_LBD is not set
+CONFIG_LBD=y
 # CONFIG_LDM_PARTITION is not set
 CONFIG_LEDS_CLASS=y
 CONFIG_LEDS_TRIGGER_DEFAULT_ON=y
index 3de18d7..2973ff5 100644 (file)
@@ -1047,7 +1047,7 @@ CONFIG_KMOD=y
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
 # CONFIG_LATENCYTOP is not set
-# CONFIG_LBD is not set
+CONFIG_LBD=y
 # CONFIG_LCD_LTV350QV is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
index 5d571fe..6c8c4d3 100644 (file)
@@ -1049,8 +1049,7 @@ CONFIG_KMOD=y
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
 # CONFIG_LATENCYTOP is not set
-# CONFIG_LBDAF is not set
-# CONFIG_LBD is not set
+CONFIG_LBDAF=y
 # CONFIG_LCD_LTV350QV is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
index ed632a8..8f6efbe 100644 (file)
@@ -1108,8 +1108,7 @@ CONFIG_KMOD=y
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
 # CONFIG_LATENCYTOP is not set
-# CONFIG_LBDAF is not set
-# CONFIG_LBD is not set
+CONFIG_LBDAF=y
 # CONFIG_LDM_PARTITION is not set
 # CONFIG_LEDS_ALIX is not set
 # CONFIG_LEDS_BD2802 is not set