package/binutils: actually support the target toolchain
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 Jan 2015 16:02:59 +0000 (16:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 Jan 2015 16:02:59 +0000 (16:02 +0000)
This fixes a bug, where ld on ARM EABI platforms expects OABI code.

Signed-off-by: Harald Geyer <harald@ccbib.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43866 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/binutils/Makefile

index cf77690..c5a0717 100644 (file)
@@ -69,6 +69,8 @@ endef
 TARGET_CFLAGS += $(FPIC) -Wno-unused-value
 
 CONFIGURE_ARGS += \
+       --host=$(REAL_GNU_TARGET_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
        --enable-shared \
        --enable-install-libiberty \
        --enable-install-libbfd