fix uboot not building
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 May 2008 19:07:16 +0000 (19:07 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 May 2008 19:07:16 +0000 (19:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11100 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/avr32/image/u-boot/Makefile

index ec4f7fb..a24efc4 100644 (file)
@@ -29,7 +29,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(CONFIG_AVR32_UBOOT_TARGET).bin bs=64k conv=sync
+       mkdir -p $(BIN_DIR)
+       dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(UBOOT_CONFIG).bin bs=64k conv=sync
 endef
 
 $(eval $(call Build/DefaultTargets))