[kernel] switch to 2.6.27.12
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jan 2009 13:30:27 +0000 (13:30 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jan 2009 13:30:27 +0000 (13:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14157 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/adm5120/patches-2.6.27/001-adm5120.patch
target/linux/ar71xx/Makefile
target/linux/au1000/Makefile
target/linux/brcm63xx/Makefile
target/linux/generic-2.6/patches-2.6.27/900-headers_type_and_time.patch
target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch
target/linux/ifxmips/Makefile
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/x86/Makefile

index 78e8ef4..a88da93 100644 (file)
@@ -28,8 +28,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.26.8)
   LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
 endif
-ifeq ($(LINUX_VERSION),2.6.27.11)
-  LINUX_KERNEL_MD5SUM:=29bf3e01673b42f7bf993aa8295b8245
+ifeq ($(LINUX_VERSION),2.6.27.12)
+  LINUX_KERNEL_MD5SUM:=3a81aa35effee2656cd0340f665d4f34
 endif
 ifeq ($(LINUX_VERSION),2.6.28)
   LINUX_KERNEL_MD5SUM:=d351e44709c9810b85e29b877f50968a
index 5a5c5ab..180086a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index 1f09d00..c16b6b7 100644 (file)
@@ -22,7 +22,7 @@
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
-@@ -598,6 +612,7 @@ config WR_PPMC
+@@ -598,6 +613,7 @@ config WR_PPMC
  
  endchoice
  
index b7aa42c..8db27eb 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx
 FEATURES:=squashfs tgz
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6c49ee8..1650991 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini yamonenv
index d2612cf..6523eef 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 
index b123872..6350cb9 100644 (file)
@@ -11,7 +11,7 @@
  #include <linux/types.h>
  
  #ifdef __KERNEL__
-@@ -228,4 +232,6 @@ struct itimerval {
+@@ -229,4 +233,6 @@ struct itimerval {
   */
  #define TIMER_ABSTIME                 0x01
  
index c18eea4..ebed01d 100644 (file)
@@ -88,7 +88,7 @@
  /*********************************************************************
 --- a/fs/fcntl.c
 +++ b/fs/fcntl.c
-@@ -140,6 +140,7 @@ asmlinkage long sys_dup(unsigned int fil
+@@ -140,6 +140,7 @@ SYSCALL_DEFINE1(dup, unsigned int, filde
        }
        return ret;
  }
index 3328960..8e96f7c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
 SUBTARGETS:=generic nfs
 LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.11
+#LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
index 2a4fb06..f5499ee 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index b83439d..e1fedf7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index deed81e..048e333 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 1f76348..f6100c5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.27.11
+LINUX_VERSION:=2.6.27.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci