eglibc: fix mips64 abi selection, default to o64 instead of n32
authorFelix Fietkau <nbd@openwrt.org>
Sat, 31 May 2014 12:30:39 +0000 (12:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 31 May 2014 12:30:39 +0000 (12:30 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40888 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/eglibc/common.mk

index f1e3f30..81f3df5 100644 (file)
@@ -34,6 +34,9 @@ HOST_STAMP_CONFIGURED:=$(CUR_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(CUR_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_$(VARIANT)_installed
 
+ifeq ($(ARCH),mips64)
+  TARGET_CFLAGS += -mabi=64
+endif
 
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \