[package] fix incorrect quoting in busybox cron init script
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 17:29:17 +0000 (17:29 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 17:29:17 +0000 (17:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14540 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/files/cron

index ae37904..b0f0fc8 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.11.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
index 9a31392..f247130 100755 (executable)
@@ -3,7 +3,7 @@
 START=50
 
 start () {
-       [ -z $(ls /etc/crontabs/) ] && exit 1
+       [ -z "$(ls /etc/crontabs/)" ] && exit 1
        mkdir -p /var/spool/cron
        [ -L /var/spool/cron/crontabs ] || ln -s /etc/crontabs /var/spool/cron/crontabs
        crond -c /etc/crontabs