imx6: drop ventana kernel/rootfs hack
authorLuka Perkov <luka@openwrt.org>
Fri, 8 Aug 2014 13:38:25 +0000 (13:38 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 8 Aug 2014 13:38:25 +0000 (13:38 +0000)
In r41578 this was added in order to make default images bootable for the BB
release. We need more generic approach for this.

Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42071 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/imx6/image/Makefile

index 54cdfd5..2e2e11b 100644 (file)
@@ -42,9 +42,9 @@ endef
 
 define Image/InstallKernel/Template
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
-   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
+   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
        $(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
        ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
    endif
@@ -59,7 +59,7 @@ define Image/InstallKernel/Template
    endif
  endif
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
        $(foreach dts,$(shell echo $(1)), \
                $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \