package/kernel: only include i2c-of if CONFIG_OF enabled
authorGabor Juhos <juhosg@openwrt.org>
Sat, 6 Apr 2013 16:55:25 +0000 (16:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 6 Apr 2013 16:55:25 +0000 (16:55 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36227 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/i2c.mk

index 5cf929d..0855708 100644 (file)
@@ -22,9 +22,12 @@ endef
 
 I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
-  CONFIG_OF_I2C:drivers/of/of_i2c \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
+ifeq (CONFIG_OF,y)
+  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
+endif
+
 define KernelPackage/i2c-core
   $(call i2c_defaults,$(I2C_CORE_MODULES),51)
   TITLE:=I2C support